Exhcange 2010 Uninstall Problem - ORF Forums

Exhcange 2010 Uninstall Problem RSS Back to forum

1

We installed the Trial version on our Server 2008 running Exchange 2010, And when we went to uninstall it said that we had to stop the Transport Service, I stopped the server and continued with the uninstall..

During the uninstall a error came up(http://i51.tinypic.com/2dj1mwh.jpg)
and now I can no longer open the Exchange Management Console or the Shell..

Opening the Console gives us this Error msg

you cannot call a method on a null-valued expression. It was running the command 'Discover-ExchangeServer -UseWIA $true -SuppressError $true -CurrentVersion 'Version 14.1 (Build 218.15)

by Ron 8 years ago
2

@Ron: This looks like an Exchange issue that affects ORF as well - essentially, these are the same error messages. During the uninstallation, ORF issues two Uninstall-TransportAgent commands to remove its Transport Agents (which connect Exchange and ORF), and one of these commands fail with the same error. I suspect the Exchange Management Console gives a similar error, is that correct? Given the scope of the error is outside ORF, this has to be fixed in Exchange.

I did a search for this specific error in Exchange 2010 and found that it has numerous possible causes, but typically Exchange installation/upgrade (SP1) errors like here: http://social.technet.microsoft.com/Forums/en-US/exchangesvradmin/thread/6c9a3823-8c87-4763-9a03-db6d41a10703/ . Did you install Exchange 2010 SP1, or reconfigured the role settings recently?

by Peter Karsai 8 years ago
(in reply to this post)

3

@Peter Karsai: No, ORF Trial was installed and left on for a couple hours then we removed it. the EMC and Shell both ran prior to installing and when ORF was installed they both stopped working after ORF was uninstalled.

I have tried reinstalling ORF again and it gives an error during the install along the lines of the error i get when uninstalling.

by Ron 8 years ago
(in reply to this post)

4

@Ron: I found some errors that might help with the problem

MSExchange Extensibility
Category: MExRuntime
Message:

Failed to create agent factory for the agent 'Vamsoft ORF SMTP Receive Agent' with error 'Failed to create type 'Vamsoft.ORF.TransportAgents.VSSmtpReceiveAgentFactory' from assembly 'C:\Program Files (x86)\ORF Enterprise Edition\orftagent.dll' due to error 'Invalid agent assembly path.'.'. Please verify the corresponding transport agent assembly and dependencies with correct version are installed.


MSExchangeTransport
Category: Configuration
Message:

Microsoft Exchange couldn't start transport agents. The Microsoft Exchange Transport service will be stopped. Exception details: Failed to create type 'Vamsoft.ORF.TransportAgents.VSSmtpReceiveAgentFactory' from assembly 'C:\Program Files (x86)\ORF Enterprise Edition\orftagent.dll' due to error 'Invalid agent assembly path.'. : Microsoft.Exchange.Data.ExchangeConfigurationException: Failed to create type 'Vamsoft.ORF.TransportAgents.VSSmtpReceiveAgentFactory' from assembly 'C:\Program Files (x86)\ORF Enterprise Edition\orftagent.dll' due to error 'Invalid agent assembly path.'. ---> System.ArgumentException: Invalid agent assembly path.

--- End of inner exception stack trace ---

at Microsoft.Exchange.Data.Transport.Internal.MExRuntime.FactoryTable.CreateAgentFactory(AgentInfo agentInfo)

at Microsoft.Exchange.Data.Transport.Internal.MExRuntime.FactoryTable..ctor(IEnumerable agents)

at Microsoft.Exchange.Data.Transport.Internal.MExRuntime.RuntimeSettings..ctor(MExConfiguration config, String agentGroup)

at Microsoft.Exchange.Data.Transport.Internal.MExRuntime.MExRuntime.Initialize(String configFile, String agentGroup, Boolean isBridgeHead, String installPath)

at Microsoft.Exchange.Transport.Extensibility.AgentComponent.Load()

by Ron 8 years ago
(in reply to this post)

5

@Ron: You might want to try removing the TrasportAgents of ORF remotely (e.g., by installing Exchange Management Tools on a separate client if the local EMC won't start) by running

Uninstall-TransportAgent -Identity "Vamsoft ORF Routing Agent"
Uninstall-TransportAgent -Identity "Vamsoft ORF Receive Agent"

If that does not work, you can also try to disable them (using the Disable-TransportAgent command).

by Krisztian Fekete 8 years ago
(in reply to this post)

New comment

Fill in the form below to add a new comment. All fields are required. If you are a registered user on our site, please sign in first.

It will not be published.
hnp1 | hnp2