Need help Moving SQl Database to new SQL Server RSS

1

Currently Exchange 2010 Enterprise on Windows 2008 R2 ORF 5.4 SQL DB on Windows 2008 R2 Server with SQL 2008.
Just built Windows 2012 R2 Cluster with SQL 2014 Enterprise
Need to move the database to the SQL 2014 Server.

Followed these instructions.

1. Stop ORF Service on SERV025
2. Detach ORF DB on SERV010
3. Copy ORF DB File to c:\temp
4. Copy ORF DB to E:\SQLData on SERV014-N1
5. Attach ORF DB on SERV014-N1
6. Start ORF Service on SERV025
7. Use ORF Administration Tool
a. Whitelists > Auto Sender Whitelist select database then select configure modify the string and click on the test connection button
b. Blacklists same procedure as A
i. DHA Protection Test
ii. Graylisting
iii. Honeypot Test

This connection String works

Provider=sqlncli10;server=SERV010,1433;database=ORF;User Id=orfuser;Password=xxxxxxxxxxxx;DataTypeCompatibility=80;

This one fails
Provider=sqlncli10;server=SERV014-N1-SQLC,1433;database=ORF;User Id=mydom\sqladmin;Password=xxxxxxxxxxxxx;DataTypeCompatibility=80;

Test failed could not connect to the database
error message
TCP Provider A connection attempt failed because the connected party did not properly respond after a period of time or established connection failed because connected host has failed to respond

I can not connect with a local account either

I event tried using sa account no luck

by Tom 3 months ago
2

@Tom: Hello Tom,

I think the issue is with the argument of the 'Provider' property in the connection string - it should be SQLNCLI11. Have you updated the SQL Server Native Client to 11.0 on the ORF server to match the version on the new SQL Server? To verify this, run the ODBC Data Source Administrator tool (C:\Windows\System32\odbcad32.exe), select the Driver tab and look for the SQL Server Native Client 11.0 entry. If it is missing, download it (from https://www.microsoft.com/en-us/download/details.aspx?id=50402) and install it on the ORF server. Then, try again.

Let me know if this has helped.

by Daniel Novak (Vamsoft) 3 months ago
(in reply to this post)

3

@Tom: The error message could also indicate that the SQL server is not prepared to accept connections on the given IP/port. You should double check the (TCP/IP) protocol settings in the "SQL Server Configuration Manager":

1. Select the “Protocols for SQLEXPRESS” node under “SQL Network Configuration”.
2. Right click on “TCP/IP” and click Enable (TCP/IP is disabled by default).
3. Right click on “TCP/IP” again and select Properties.
4. If you want the server to accept connections from all IPs, select "Yes" from the "Listen All" dropdown, on the "Protocol' tab - otherwise, select "No".
5. Select the “IP Addresses” tab.
6. If you want the server to accept connections from all IPs, scroll down to "IPAll", if not, find the network interface you wish to use. Then, delete “0” from “TCP Dynamic Ports” (or leave it as is, if you want to use dynamic ports).
7. Enter a port number to use in the “TCP Port” field (e.g. 1754) and make sure that the network interface is enabled ("Enabled" field: Yes/No), and that the port is open on the server’s firewall(!).
8. Click Apply and OK.
9. Restart the SQL Server Service.

You can run the command "telnet [IP/hostname] [port]" from the windows command prompt on the SQL server (and on the ORF server as well) to test the settings. If everything is set up properly, you should be able to connect. Otherwise, you will receive the message: "Could not open connection to the host, on port [port]: Connect failed"

If none of this helps, I would suggest consulting the following SQL connectivity troubleshooting guide from Microsoft: https://docs.microsoft.com/en-us/sql/database-engine/configure-windows/troubleshoot-connecting-to-the-sql-server-database-engine?view=sql-server-2017

by Daniel Novak (Vamsoft) 3 months ago
(in reply to this post)

4

Thank you all for responding

Adding the SQLNCLI11 and then changing my SQL authentication mode to Mixed solved the problem.

Thank you for your support

Tom

by trgrassijr 3 months ago
5

@trgrassijr: I am glad to hear that :) If anything else comes up, just let us know.

by Daniel Novak (Vamsoft) 3 months ago
(in reply to this post)

New comment

Fill in the form below to add a new comment. All fields are required. If you are a registered user on our site, please sign in first.

Nickname:
Email address (will not be published):
Your comment:

ORF Technical Support

Configuring, installing and troubleshooting ORF.

News & Announcements

Your dose of ORF-related news and announcements.

Everything but ORF

Discuss Exchange and system administration with fellow admins.

Feature Test Program

Feature Test Program discussion. Membership is required to visit this forum.

ORF Beta

Join the great bug hunt of the latest test release.

Customer Service

Stay Informed