Test Issues on new Exchange Server - ORF Forums

Test Issues on new Exchange Server RSS Back to forum


I installed and added a new Exchange 2016 server to the already Exchange 2010 organization. The settings are the same on both exchange servers.
When I send mail from myself to myself on both servers they fail with keyword blacklist I created for preventing to send mail as someone else in the company.
When I send mail from gmail.com from my house to Ex2010, I get a SPF fail which it should be.
When I send mail from gmail.com from my house to Ex2016, it passes through. It's as if the SPF test didn't get triggered.
If I set SPF to "On Arrival" and do the same thing it does catch it. So my question is why does the "Before Arrival" not get triggered anymore? Is it 2016 or something?

Further testing, any test on "Before Arrival" isn't being triggered, but "On Arrival" is.


by Jean 3 years ago

@Jean: Hello Jean,

Since ORF whitelists internal and outbound emails automatically, I suspect that there is an issue with settings of the Send/Receive connectors of Exchange, but I cannot tell for sure based on the information provided. Could you send us (to ) your ORF configuration file (orfent.ini) and a couple of recent ORF log files (e.g. orfee-2016-08-20.log, orfee-2016-08-21.log), along with a short description of your system setup (i.e. server topology information, primary/secondary mail servers, smart-hosts, firewalls etc.) for analysis? I will need to review them to investigate this issue. The requested files can be found in the ORF program directory by default (\Program Files (x86)\ORF Fusion).

by Daniel Novak (Vamsoft) 2 years ago
(in reply to this post)


@Daniel Novak (Vamsoft): Email sent.

by Jean 2 years ago
(in reply to this post)


Thank you ORF support and Daniel. I'm going to post the real problem in layman terms and the fix.
System's Effected:
Exchange 2016

All "Before Arrival" tests do not get triggered. If you change it to "After Arrival", the tests will trigger.

The SMTP receiver connector on Ex2016 is probably set as HubTransport instead of FrontendTransport. ORF's "Before Arrival" will only check on Frontend Transports. There is a bug on atleast Exchange 2016 CU2 Admin Center where if you create a receive connector it defaults to HubTransport and you can't select FrontendTransport even if you try. This bug does not exist on Exchange 2013.

The Fix:
Set the receive connector to FrontendTransport assuming that is what you want, if you're creating one then you probably do. This has to be done from EMS (Exchange Management Shell) as the EAC (Exchange Admin Center) is screwed up. Run:
Set-ReceiveConnector "Receive Connector" -TransportRole "FrontendTransport"

by Jean 2 years ago

Thank you for sharing this information with the ORF community Shawn. I am sure it will prove helpful to many.

by Daniel Novak (Vamsoft) 2 years ago

I have the same problem. "Before Arrival" tests do not get triggered. The receive connector is set as Frontend Transport.
I have installed Exchange 2016 CU8.
I tried to change the priority.

by dit.fdoctor 1 year ago

Hello dit.fdoctor,

Could you tell us more about your system and provide additional details, please?

- When did this issue start?
- Was ORF working properly with Exchange 2016 CU7 and earlier versions?
- If you have more ORF servers, are all of them affected?
- Which ORF version are you using?
- Which Exchange role is installed on the mail exchanger?
- Is the logging of *all* Before Arrival events enabled in ORF? (Administration Tool > Log > ORF Text Log > Configure) - if not, mark them enabled and save the configuration (Ctrl+S)
- Are there *any* Before Arrival events recorded in the ORF logs? (Log Viewer > Connect > View Recent Logs...: sort by 'Filtering Point' column)

by Daniel Novak (Vamsoft) 1 year ago

Hello, Daniel.
This issue start immediately.
I installed Exchange 2016 CU8 Mailbox role on new server without CU7 or earlier.
Second server with ORF working normally with Exchange 2010 SP3 Edge role.
I use ORF 5.5 and all events enabled for logging.
There are no Before Arrival events in the logs.
Server with Exchange 2016 and ORF is a publisher and the configuration is taken from it.

by Aleksandr 1 year ago

And additionally if I disable "Vamsoft ORF SMTP Receive Agent" on the Hub, then the mail goes past ORF. In this case no new events appears in the logs.

by Aleksandr 1 year ago

@Aleksandr: That is normal behavior. When you disable the "Vamsoft ORF SMTP Receive Agent", you take away ORF's ability to access the incoming emails.

You mentioned that you tried to change ORF's priority already. Have you assigned the highest priority (1) to "Vamsoft ORF SMTP Receive Agent" on the transport agent list? If not, please do so (see: https://vamsoft.com/support/docs/knowledge-base/filtering-order-exch2k16) and keep it that way while we investigate this issue.

In addition, please send us (to ) the ORF configuration file (orfent.ini) from the affected server and a couple of ORF log files that were created after you changed the Vamsoft ORF SMTP Receive Agent's priority to 1. The configuration file and the logs (e.g. orfee-2018-06-20.log, orfee-2018-06-21.log) can be found in the ORF program directory (default: \Program Files (x86)\ORF Fusion\).

Thank you!

by Daniel Novak (Vamsoft) 1 year ago
(in reply to this post)


But I disabled the agent only for Hub, not for Frontend.
I already set the highest priority.
I sent files from e-mail , but I can't the exact time when I changed the priority.

by Aleksandr 1 year ago

I just saw that it worked, but I don't know exactly after what actions.
I guess that after restart the Frontend although Exchange requires restart MSExchangeTransport only.

by Aleksandr 1 year ago

Daniel, thank you for help.
ORF works as it should.

by Aleksandr 1 year ago

Thank you for the update Aleksandr!

I am glad to hear that the issue has been resolved. Nonetheless, I will try to reproduce this case in our labs to figure out what might cause (and fix) such behavior.

by Daniel Novak (Vamsoft) 1 year ago

We are migrating our exchange server to office 365 cloud services
. How can still use your product.

by Jchan 12 months ago

@Jchan: Hello Jchan,

ORF is a server-side only software, so cloud-based solution are not supported. Unless you are running a hybrid Exchange environment, your only option is to set up an IIS SMTP server which receives all incoming emails first, then relays them (now filtered by ORF) to Office 365: http://technet.microsoft.com/en-us/library/dn592151(v=exchg.150).aspx

I hope this helps.

by Daniel Novak (Vamsoft) 11 months ago
(in reply to this post)

New comment

Fill in the form below to add a new comment. All fields are required. If you are a registered user on our site, please sign in first.

It will not be published.
hnp1 | hnp2