ORF 5.1 Beta R1: Migrating from 2010 to 2013 - ORF Forums

ORF 5.1 Beta R1: Migrating from 2010 to 2013 RSS Back to forum


In my LAB (all virtual), I had Exchange 2010 (all roles/single server) with ORF 5.0.
Then installed new Windows 2012 with Exchange 2013 (again all roles/single server).
Migrated all mailboxes from E2010 to E2013, and removed mailbox role from E2010.
Inbound email coming via E2010 with ORF, outbound email from E2013.
Goal is now to install ORF 5.1 on E2013 (KB scenario B), and remove/uninstall E2010.
I am planning on first upgrading ORF 5.0 to 5.1 on the old server first.
How do I best MIGRATE all settings (logs, DNSBL, whitelists, blacklists, e.t.c.) from the old E2010 installation to the new E2013 installation.
I suspect there are settings I should NOT try to bring over, because of different architecture?

by JTSolem 6 years ago

@JTSolem: Actually, you can bring everything over.

1) Do a configuration backup on your Exchange 2010 server. I recommend following the Migration Guide, which details the steps specifically for this scenario: http://vamsoft.com/support/docs/how-tos/migration-5.0

You can follow the same guide for ORF 5.0 and ORF 5.1, the list of files used by ORF did not change.

2) Install ORF 5.1 on the Exchange 2013 server, but do not launch any of the tools yet.

3) Restore the configuration backup on the Exchange 2013 server.

4) Open the Administration Tool and review your settings. In particular,
- be sure to re-detect the Replay Directory path (System / Microsoft Exchange page)
- look for different file system paths
- look for DNS server changes
- look for Intermediate Host List changes
- apply filtering point changes, if necessary

5) Save your configuration.

6) Start the ORF Service.

by Péter Karsai (Vamsoft) 6 years ago
(in reply to this post)


@Péter Karsai (Vamsoft): Thank you very much, P├ęter.
I'll give it a go then :-)

by JTSolem 6 years ago
(in reply to this post)


@JTSolem: Thanks, let me know if anything comes up. We did a few test migrations, but they were in-place and every environment is different.

by Péter Karsai (Vamsoft) 6 years ago
(in reply to this post)


@Péter Karsai (Vamsoft): OK, a short update:
I have now done everything as outlined above. Copied all settings files from the old server as outlined in the Configuration Backup Guide. Before starting the ORF Administration Tool, I checked all INI-files and changed paths:
Old installation was in Program files\ORF Enterprise Edition
New installation is in Program files\ORF Fusion
I then started ORF Administration Tool, and tried to detect the Exchange Replay directory:
For some reason the detection insisted that the replay directory is:

C:\Program Files\Microsoft\Exchange Server\V14\TransportRoles\Replay\
I manually changed the \V14\ to \V15\, and saved config.

Started the ORF service, and enabled incoming port 25, and set to NAT through to E2013 on the firewall. Test mails from outside seems to work OK.
Now I'm going to uninstall ORF and Exchange 2010 from the old server, and see how that goes...

by JTSolem 6 years ago
(in reply to this post)


@JTSolem: Thanks.

About the Replay Directory: if you open an Exchange Management Console and run "Get-TransportService | fl", is only one object returned? If so, what is the value of the ReplayDirectoryPath field? How about if you repeat it with "Get-TransportServer | fl"? (these should be the very same PowerShell commands, but Get-TransportServer was renamed to Get-TransportService in Exchange 2013).

by Péter Karsai (Vamsoft) 6 years ago
(in reply to this post)


@Péter Karsai (Vamsoft): OK, next update:
I have now uninstalled Exchange 2010, and switched off the server (will remove from AD later). I have also rebooted the Exchange 2013 server, and checked in the EAC (GUI) that I no longer have any references to the old server.
Now, when I again try to autodetect the Relay Directory in ORF, it returnes the correct \V15\ path!
Running "Get-TransportService | fl", (in the long list returned) I can only find one instance of "ReplayDirectoryPath" which is the new correct one.
Maybe I could have helped you "bugfix", if I had not uinstalled the old server? Perhaps a note in the documentation is in order, about multiple "ReplayDirectoryPath" in a coexistence environment?

by JTSolem 6 years ago
(in reply to this post)


@JTSolem: You figured out what I was suspecting :) It could be that Get-TransportService returns the Exchange 2010 transport in this setup, or it returns multiple transport service objects.

The second should be possible according to the documentation, but only if you have multiple Exchange 2013 Mailbox Servers in your organization. If one of those was in-place upgraded from Exchange 2010 to Exchange 2013, then I guess the Replay Directory path could have remained the same.

The documentation also sort of leaves the option open to include your Exchange 2010 server if it wasn't just Edge Transport, but included mailboxes as well.

Did any of the above apply to your setup?

by Péter Karsai (Vamsoft) 6 years ago
(in reply to this post)


@Péter Karsai (Vamsoft): If I understood you correctly, yes.
I definately had another transport service eith the old E2010(see my first message).
I never had any Edge Transport, and I did not (off course?) do any inplace upgrade.

Anyway, I now know what to check and look for, when time eventually come to upgrade the production environment!

by JTSolem 6 years ago
(in reply to this post)


@JTSolem: We will try this with a coexistence setup and see if the issue reproduces. Thank you.

by Péter Karsai (Vamsoft) 6 years ago
(in reply to this post)


Method: Migrate the mailboxes from Exchange 2010 to 2013

1. Export Exchange Server 2010 mailboxes to PST

New-MailboxExportRequest -Mailbox XYZ -FilePath ""\\SERVER01\XYZ.pst""

2. Import Outlook PST files into Exchange Server 2013

New-MailboxImportRequest -Mailbox XYZ -FilePath \\SERVER01\NXYZ.pst -TargetRootFolder ""RecoveredFiles""

For more info read it : http://exchangeservermigration.blogspot.com

by mcbee jim 6 years ago

New comment

Fill in the form below to add a new comment. All fields are required. If you are a registered user on our site, please sign in first.

It will not be published.
hnp1 | hnp2