SQL Error on DHA Protection Test - ORF Forums

SQL Error on DHA Protection Test RSS Back to forum

1

I have set up SQL Express on one Edge Transport server as the publisher.
I am getting an error from one of the Edge Transport servers, the subscriber. The database connection tests OK.

Error EOleException cleaning up expired database items. Database: DHA Protection Test. Error: "SQL Server Network Interfaces: Error Locating Server/Instance Specified [xFFFFFFFF]".

by aflowers 6 years ago
2

@aflowers: Either the server name or instance name specified in the connection string is incorrect, or something prevents the connection (firewall). Here are some troubleshooting tips:

http://blogs.msdn.com/b/spike/archive/2010/06/21/quot-error-locating-server-instance-specified-xffffffff-quot-sqlsrv32-to-the-rescue.aspx

http://blogs.msdn.com/b/sql_protocols/archive/2007/05/13/sql-network-interfaces-error-26-error-locating-server-instance-specified.aspx

Another cause may be a bug affecting failover cluster instances (not sure if this applies):

http://support.microsoft.com/kb/944390

by Krisztián Fekete (Vamsoft) 6 years ago
(in reply to this post)

3

I have checked everything again. When I test the connection, the tests are successful.

I get this error in the log files regarding the DHA.

Now I am getting the message when trying to add to the AutoSender Whitelist.

No failover. Just SQL Express 2008 running on one of the Edge Transport servers, and the other Edge Transport server connecting as a Subscriber.

by aflowers 6 years ago
4

@aflowers: Have you tried the troubleshooting tips described in the articles I sent? Do you get error 53 or 67 when trying to connect using ODBC? Did you test the connection using PortQry to rule out the possibility that your firewall blocks the UDP packets of SQL Browser?

by Krisztián Fekete (Vamsoft) 6 years ago
(in reply to this post)

5

No, but I will. I assumed that, if I got a connection during testing, the connection string must be OK. If not, it would not pass the test.

If the connections worked sometimes, would that not rule out a connection string or firewall problem?

Should I just have all my outbound email go out through one server?

by aflowers 6 years ago
6

@aflowers: Does your firewall limit network access by process or user? It could be that the ORF Administration Tool (orfeeadm.exe), running in the administrator's user security context gets different right from the ORF Service (orfeesvc.exe), running under the security context of the LocalService account.

Also, the subscriber server should have the necessary ports open for SQL access, too.

by Péter Karsai (Vamsoft) 6 years ago
(in reply to this post)

New comment

Fill in the form below to add a new comment. All fields are required. If you are a registered user on our site, please sign in first.

It will not be published.
hnp1 | hnp2