ORF Service not Starting After Reboot RSS

1

Hi.

Our ORF Service is not starting on our Exchange 2003 Server after a reboot due to an Exchange configuration change. Not sure if thats related, we added gthe HTTP over RPC proxy functionality.
The Event viewer shows a "The ORF Service service failed to start due to the following error:
ORF Service is not a valid Win32 application." message with a 7000 ID.

IF you try and start the service manually the following message is displayed "Could not start the ORF Service on local computer Error 193: 0xc1". We are running ORF Enterprise v4.3.

Anyone any ideas. Thanks.

by jason.blake 6 years ago
2

@jason.blake: Please try reinstalling the ORF service by running the following commands as Administrator in the ORF directory (Program Files \ ORF Enterprise Edition (x86) by default):

orfeesvc.exe -uninstall
orfeesvc.exe -install

Then attempt to start it. If this does not help, try rebooting the server one more time. If that does not solve the problem either, please let us know and we will investigate further.

by Krisztián Fekete (Vamsoft) 6 years ago
(in reply to this post)

3

@Krisztián Fekete (Vamsoft): Hi Kris.

Tried what you suggested and its still the same even after a reboot. Looking up the 193: 0xc1 message this can point to a path statement being wrong for service exe. I checked this out for the ORF service image path in the registry and all seems to be fine. (C:\Program Files\ORF Enterprise Edition\orfeesvc.exe) This is the article I followed.

http://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/error-193-0xc1-when-trying-to-start-windows-audio/77795eee-56c3-468d-b32c-be5987797dec

Interesting is that the Nagios client software is also failing with the same error upon starting of the service. Any ideas ?

by jason.blake 6 years ago
(in reply to this post)

4

@jason.blake: A possible cause of this problem according to our lead developer is that the Windows Service API registers the ORF service in a way that the file path to the executable file orfeesvc.exe (which contains a space character) is not enclosed with double quotes. This may cause Windows to look for the executable in "c:\Program" instead of "c:\Program Files\ORF Enterprise Edition", hence the "not a valid Win32 application" error. Probably that causes the issue with the Nagios service, too.

To solve the problem, you should edit the registry entries of these services (I think in HKLM\SYSTEM\CurrentControlSet\Services, the ORF Service keys are stored under VSORFEE) so that the file paths are enclosed with double quotes. (Simply double-click the ImagePath key and enclose the content of "Value data" with double quotes).

Please let us know if this has helped.

by Krisztián Fekete (Vamsoft) 6 years ago
(in reply to this post)

5

@Krisztián Fekete (Vamsoft): Hi Kris.

The "" in the path solved the problem. Maybe something happened with the interpretation of path names after a recent windows update and reboot to cause the symtoms.

Jason.

by jason.blake 6 years ago
(in reply to this post)

6

@jason.blake: I am glad to hear the problem has been solved :)

by Krisztián Fekete (Vamsoft) 6 years ago
(in reply to this post)

New comment

Fill in the form below to add a new comment. All fields are required. If you are a registered user on our site, please sign in first.

Nickname:
Email address (will not be published):
Your comment:

ORF Technical Support

Configuring, installing and troubleshooting ORF.

News & Announcements

Your dose of ORF-related news and announcements.

Everything but ORF

Discuss Exchange and system administration with fellow admins.

Feature Test Program

Feature Test Program discussion. Membership is required to visit this forum.

ORF Beta

Join the great bug hunt of the latest test release.

Customer Service

Stay Informed