Management tools not working with remote connect - ORF Forums

Management tools not working with remote connect RSS Back to forum

1

Hello,

I have a problem using the management tools version 5.4 to connect to my ORF Server.
I am receiving when trying to connect to it. Full errors:
error code 0x00002EFD
error code 0x00002EE2
I get this error when connecting to 'ip:6242'
The version on the server is also 5.4.
When I turn all the firewalls of on both sides it is still not working and I receive the 0x00002EFD error. When I turn the Firewall on at the server I receive the second error 0x00002EE2.

How can I fix this?

by rené.klomp 5 years ago
2

@rené.klomp: Hello RenĂ©,

Both error codes indicate a connection error (0x00002EFD means "cannot connect", 0x00002EE2 means "connection timeout"), so I think the ORF Service is simply not listening on IP:6242. Please verify your remote access settings on the System / Remote Access page of the Administration Tool. Specifically,

* The Remote Access service should be enabled
* The Local Bindings list should contain an "All Interfaces:6242" binding or an IP-specific binding
* The remote host IP must be on the Allowed IPs list with "All Services" or "Only Remote Administration" permission.

If these look OK, please make sure to save your configuration just in case the changes you made previously were not applied for some reason.

In any case, the ORF Service must be specifically allowed through the firewall.

Did the above help?

by Péter Karsai (Vamsoft) 5 years ago
(in reply to this post)

3

Yes local bindings were set incorrectly. Resolved now.

by rené.klomp 5 years ago
4

@rené.klomp: Thank you, I am glad to hear the issue is now fixed.

by Péter Karsai (Vamsoft) 5 years ago
(in reply to this post)

5

I am unable to connect from my pc inside my network. I have the bindings set, the firewall set and the services set. I am receiving a 503 error when I try to connect.

Could not connect to server xx.xx.xx.xx:6242 due to the following problem:
HTTP error
Server returned HTTP status 503:"".

by michael_n 1 week ago
6

@michael_n: Hello michael_n,

Have you checked the "Allowed Hosts and Services" list on the ORF server to see if the connecting host is allowed to connect? (System > Remote Access > Allowed IPs). You will need to ensure that the IP of the connecting client is listed (check for possible typos) as an allowed host in the ORF server's configuration : http://vamsoft.com/r?o-hto-adm-allowedipservices . If there is a proxy between the client and the ORF server, try to connect directly (without the proxy).

by Daniel Novak (Vamsoft) 1 week ago
(in reply to this post)

7

Yes, my IP address is listed and there is no proxy. Both machines are inside my network behind the firewall. I also checked the antivirus to ensure it was not blocking the communication.

Thank you for your help.

by michael_n 1 week ago
8

@michael_n: Can you try to telnet the ORF server from the client by running the following command in the Windows Command Prompt (or PowerShell)? What message do you receive?

telnet [IP-ADDRESS-OF-ORF-SERVER] [CONFIGURED-REMOTE-ACCESS-PORT]

For example:

telnet 192.168.251.77 6242

by Daniel Novak (Vamsoft) 1 week ago
(in reply to this post)

9

telnet> open 192.168.0.21 6242
Trying 192.168.0.21...
Connected to 192.168.0.21.
Escape character is '^]'.
HTTP/1.1 503 Service Unavailable
Server: ORF Remote Access Server
Cache-Control: private, max-age=0
Connection: Close
Date: Thu, 09 Sep 2021 13:55:59 GMT

Connection closed by foreign host.

by michael_n 1 week ago
10

@michael_n: The error message indicates that the connecting client is not authorized to access the ORF service remotely. I recommend that you temporarily allow all connections from the "192.168.*" range to the ORF server (update the System > Remote Access > Allowed IPs list in the ORF Administration Tool - on the ORF server), save the ORF configuration (Ctrl + S) to apply the new settings, and try connecting again from the remote client.

by Daniel Novak (Vamsoft) 1 week ago
(in reply to this post)

11

@michael_n: I also recommend that you check the IP address of the remote client to make sure the correct IP range is added to the "Allowed IPs" list: CMD > ipconfig /all

by Daniel Novak (Vamsoft) 1 week ago
(in reply to this post)

13

What I really don't understand is why it is generating a HTTP/1.1 503 Service Unavailable error

by michael_n 1 week ago
14

@michael_n: Based on the screenshots, the server and the client might be on two different networks (192.168.0.0/24 and 162.168.0.0/24) or what is more likely that you might have added the wrong IP address to the Allowed IPs list. Try adding "*" (asterisk symbol) temporarily to the Allowed IPs list, save the configuration (Ctrl + S), and see if that solves the issue.

by Daniel Novak (Vamsoft) 1 week ago
(in reply to this post)

15

I'll give it a try and let you know. Thanks

by michael_n 1 week ago
16

still no dice
https://snipboard.io/WCtOnE.jpg

by michael_n 1 week ago
17

@michael_n: Have you saved the ORF configuration (Ctrl + S) after adding the new entries to the Allowed IPs list? If so, try restarting the ORF service, please.

Furthermore, please check the version of the Management Tools installed on the remote client and the ORF service: "Help > About ORF Fusion ...". They should be identical.

by Daniel Novak (Vamsoft) 1 week ago
(in reply to this post)

18

Yes, of course I have.
My pc: https://snipboard.io/0KJuPD.jpg
Server: https://snipboard.io/MkT3Zb.jpg

by michael_n 1 week ago
19

@michael_n: Please send us (to ) the following from the ORF server *and* the remote client and we are going to investigate the issue:

> The output of the following commands (run in CMD or PowerShell): ipconfig /all

> The ORF configuration files called orfent.ini, and the orfcs.ini* and orfcs.remote.ini* files - *if they exist. They can be found in the ORF program directory, (default: C:\ProgramData\ORF Fusion).

Thank you.

by Daniel Novak (Vamsoft) 4 days ago
(in reply to this post)

20

Sent, thank you

by michael_n 4 days ago
21

@michael_n: I meant to add, there was no orfcs.remote.ini file.

by michael_n 4 days ago
(in reply to this post)

New comment

Fill in the form below to add a new comment. All fields are required. If you are a registered user on our site, please sign in first.

It will not be published.
hnp1 | hnp2